aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-04-05 23:12:30 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-04-05 23:54:03 -0700
commit0a37f6e3cbca026d6019ef239cb4fbe645c71dce (patch)
tree30e067bbaafb27bffea5ae07a58a63bb31b70a11
parent198ea506d53bf82e1ac8ae48469acb8bd486c481 (diff)
downloadopenembedded-core-contrib-0a37f6e3cbca026d6019ef239cb4fbe645c71dce.tar.gz
cmake: remove unused dont-run-cross-binaries.patch
It hasn't been used since June 2015 when upgraded the recipe, this patch was used for crosscompiling, now the crosscompile works well without it, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch b/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
deleted file mode 100644
index 0c059f12ed..0000000000
--- a/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-cmake: don't run cross-binaries on host machine
-
-When doing the cross build we obviously cannot run those binaries on
-host since they can be binary incompatible.
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-
-Index: cmake-2.8.10.1/CMakeLists.txt
-===================================================================
---- cmake-2.8.10.1.orig/CMakeLists.txt
-+++ cmake-2.8.10.1/CMakeLists.txt
-@@ -588,7 +588,8 @@ mark_as_advanced(CMAKE_STRICT)
-
- # build the remaining subdirectories
- add_subdirectory(Source)
--add_subdirectory(Utilities)
-+# Come on! Running the cross-binaries on host is not a good idea.
-+#add_subdirectory(Utilities)
- add_subdirectory(Tests)
-
- if(BUILD_TESTING)