aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2018-04-05 16:11:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-06 11:41:01 +0100
commitca17a7bbea5f5454da43545d544ff7772d83ac19 (patch)
tree2233737c3fefa130393f0a0295899c14ebfd7af5
parent1cbbcf26e0a9ca6e0b34a89512bf75dbae8bfaf0 (diff)
downloadopenembedded-core-contrib-ca17a7bbea5f5454da43545d544ff7772d83ac19.tar.gz
hello-mod_0.1.bb: add RPROVIDES
Although the package will get an automatic prefix "kernel-module", so the package kernel-module-hello does exist, populating rootfs can generate an error: - nothing provides kernel-module-hello ... This is quite unfortunate, as this recipe is used as a sample. Adding RPROVIDES_${PN} += "kernel-module-hello" to the recipe fixes the problem. [YOCTO #12641] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
index b140b0ac8e..3d33446500 100644
--- a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -13,3 +13,5 @@ S = "${WORKDIR}"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+RPROVIDES_${PN} += "kernel-module-hello"