summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Bergin <peter@berginkonsult.se>2021-09-10 14:35:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-11 22:36:27 +0100
commit1b5648e6aeb9837cb807ce086c26fbfaa16f6f8b (patch)
treecfce92dc1e78618299eb842f093c2024497158f4
parentbb885bf8ffe9ba7260f83d9575978f753edf538e (diff)
downloadopenembedded-core-contrib-1b5648e6aeb9837cb807ce086c26fbfaa16f6f8b.tar.gz
systemd: add packageconfig for wheel-group
If the distro does not include the group 'wheel' systemd will complain when trying to parse ACL rules for tmpfiles.d. systemd-tmpfiles[273]: Failed to parse ACL "d:group:adm:r-x,d:group:wheel:r-x": Invalid argument. Ignoring Systemd has a configuration parameter to avoid using 'wheel' group in the standard config files for tmpfiles. Add this as a PACKAGECONFIG and enable it by default to keep default. Signed-off-by: Peter Bergin <peter@berginkonsult.se> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_249.3.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_249.3.bb b/meta/recipes-core/systemd/systemd_249.3.bb
index c1594d7cc5..c027b88fd6 100644
--- a/meta/recipes-core/systemd/systemd_249.3.bb
+++ b/meta/recipes-core/systemd/systemd_249.3.bb
@@ -93,6 +93,7 @@ PACKAGECONFIG ??= " \
userdb \
utmp \
vconsole \
+ wheel-group \
zstd \
"
@@ -196,6 +197,7 @@ PACKAGECONFIG[userdb] = "-Duserdb=true,-Duserdb=false"
PACKAGECONFIG[utmp] = "-Dutmp=true,-Dutmp=false"
PACKAGECONFIG[valgrind] = "-DVALGRIND=1,,valgrind"
PACKAGECONFIG[vconsole] = "-Dvconsole=true,-Dvconsole=false,,${PN}-vconsole-setup"
+PACKAGECONFIG[wheel-group] = "-Dwheel-group=true, -Dwheel-group=false"
PACKAGECONFIG[xdg-autostart] = "-Dxdg-autostart=true,-Dxdg-autostart=false"
# Verify keymaps on locale change
PACKAGECONFIG[xkbcommon] = "-Dxkbcommon=true,-Dxkbcommon=false,libxkbcommon"