aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linaro.org>2017-11-28 11:03:23 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-09 14:36:59 +0000
commitfba2c9309ede86608f985adf46592c31b5d446ca (patch)
tree40463c3ff2c1b5e40c107837e8d7b826ae154a8f
parent303d6ca5ae986acd2e633b0dc5e386ee7771f8ab (diff)
downloadopenembedded-core-contrib-fba2c9309ede86608f985adf46592c31b5d446ca.tar.gz
recipes-graphics/piglit: Add patch to fix build in some platforms
The entry point is not guaranteed to exist, so use the piglit_egl_get_default_display() helper which does the correct thing. Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/piglit/piglit/0001-tests-egl-egl-context-priority.c-Use-piglit_egl_get_.patch41
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb1
2 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-graphics/piglit/piglit/0001-tests-egl-egl-context-priority.c-Use-piglit_egl_get_.patch b/meta/recipes-graphics/piglit/piglit/0001-tests-egl-egl-context-priority.c-Use-piglit_egl_get_.patch
new file mode 100644
index 0000000000..e2e87cc1ed
--- /dev/null
+++ b/meta/recipes-graphics/piglit/piglit/0001-tests-egl-egl-context-priority.c-Use-piglit_egl_get_.patch
@@ -0,0 +1,41 @@
+From cb562a383229074b44db6998b85572d2abe7c363 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?An=C3=ADbal=20Lim=C3=B3n?= <anibal.limon@linaro.org>
+Date: Fri, 24 Nov 2017 10:31:55 -0600
+Subject: [PATCH] tests/egl/egl-context-priority.c: Use
+ piglit_egl_get_default_display
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The entry point is not guaranteed to exist, so use the
+piglit_egl_get_default_display() helper which does the correct thing.
+
+Signed-off-by: Aníbal Limón <anibal.limon@linaro.org>
+Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
+Reviewed-by: Tapani Pälli <tapani.palli@intel.com>
+Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
+
+Upstream-Status: Backport
+
+https://cgit.freedesktop.org/piglit/commit/?id=cb562a3832
+---
+ tests/egl/egl-context-priority.c | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/tests/egl/egl-context-priority.c b/tests/egl/egl-context-priority.c
+index 7f26fc614..9590ccae3 100644
+--- a/tests/egl/egl-context-priority.c
++++ b/tests/egl/egl-context-priority.c
+@@ -99,8 +99,7 @@ piglit_init(int argc, char **argv)
+ if (!strstr(exts, "EGL_MESA_platform_surfaceless"))
+ piglit_report_result(PIGLIT_SKIP);
+
+- dpy = eglGetPlatformDisplay(EGL_PLATFORM_SURFACELESS_MESA,
+- EGL_DEFAULT_DISPLAY, NULL);
++ dpy = piglit_egl_get_default_display(EGL_PLATFORM_SURFACELESS_MESA);
+
+ ok = eglInitialize(dpy, &major, &minor);
+ if (!ok) {
+--
+2.11.0
+
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index bbe9a88969..9471bd08c4 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
SRC_URI = "git://anongit.freedesktop.org/piglit \
file://0001-cmake-install-bash-completions-in-the-right-place.patch \
file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
+ file://0001-tests-egl-egl-context-priority.c-Use-piglit_egl_get_.patch \
"
UPSTREAM_CHECK_COMMITS = "1"