aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-03 20:51:35 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-05 12:28:55 +0000
commit23da8f50b1e0a74777035c9f7b65b81456908f9f (patch)
treeedfdacfa5315e9b1559dfd3c217fbfb5f9943ba3
parent33fba601a7365aced9f4b206c1fadda997076d4c (diff)
downloadopenembedded-core-contrib-23da8f50b1e0a74777035c9f7b65b81456908f9f.tar.gz
valgrind: Skip vgpreload_memcheck shared object from stripping
This is a special library for memcheck tool, where it needs to have the symbols intact for the stack traces to work on target, current option is to install valgrind-dbg ( 151 MB uncompressed ) is quite big for some systems which may not have space to install it all. Leaving it unstripped adds about 200KB to image which is much better, this alone gets memcheck working, as an aside we might need same solution for other tools e.g. helgrind etc. when needed, they also have leading libraries installed Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.14.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.14.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.14.0.bb
index 97e58a446a..50f8221ebb 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.14.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.14.0.bb
@@ -96,6 +96,19 @@ do_install_append () {
TUNE = "${@strip_mcpu(d)}"
+VALGRINDARCH ?= "${TARGET_ARCH}"
+VALGRINDARCH_aarch64 = "arm64"
+VALGRINDARCH_x86-64 = "amd64"
+VALGRINDARCH_x86 = "x86"
+VALGRINDARCH_mips = "mips32"
+VALGRINDARCH_mipsel = "mips32"
+VALGRINDARCH_mips64el = "mips64"
+VALGRINDARCH_powerpc = "ppc"
+VALGRINDARCH_powerpc64 = "ppc64"
+VALGRINDARCH_powerpc64el = "ppc64le"
+
+INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
+
RDEPENDS_${PN} += "perl"
# valgrind needs debug information for ld.so at runtime in order to