summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-02-22 09:21:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-23 22:31:26 +0000
commita748e6098fa7d2ff594319937c7e0cf97700e83a (patch)
tree93dd707207e9c4a6e222270f14487e5cdc128644
parent6d688cc8672b1830ba10966492ab3f8a12d32e17 (diff)
downloadopenembedded-core-contrib-a748e6098fa7d2ff594319937c7e0cf97700e83a.tar.gz
python3: Fix python interpreter line length for nativesdk
Make sure the python interpreter is "#!/usr/bin/env python3" for nativesdk to avoid the shebang path exceeding the limit when install the sdk under the directory with long path. Before: $ cd ${target_sdk_dir} $ vi ./sysroots/x86_64-oesdk-linux/usr/bin/2to3 #!${target_sdk_dir}/sysroots/${SDK_SYS}/usr/bin/python3.9 [snip] After: $ cd ${target_sdk_dir} $ vi ./sysroots/x86_64-oesdk-linux/usr/bin/2to3 #!/usr/bin/env python3 [snip] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3_3.9.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.9.2.bb b/meta/recipes-devtools/python/python3_3.9.2.bb
index 87231f97a6..9c87d9d2eb 100644
--- a/meta/recipes-devtools/python/python3_3.9.2.bb
+++ b/meta/recipes-devtools/python/python3_3.9.2.bb
@@ -177,6 +177,10 @@ do_install_append() {
}
do_install_append_class-nativesdk () {
+ # Make sure we use /usr/bin/env python
+ for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
+ done
create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
}