summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-03-02 10:25:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-02 20:35:08 +0000
commitd2365442568c206a13165f8c71a7b7a5d0c6ff4e (patch)
treea83f90a2de04d112874a43255d5f42c6ae0dcf66
parent647cd1134a543406f0f741d3f83d5f5ce78bcd0f (diff)
downloadopenembedded-core-contrib-d2365442568c206a13165f8c71a7b7a5d0c6ff4e.tar.gz
coreutils: use u-a for base32
* busybox 1.33.0 added base32 applet and now do_rootfs for read-only images is failing with: do_rootfs: busybox.postinst returned 1, marking as unpacked only, configuration required on target. ERROR: image-devel-1.0-r2 do_rootfs: Postinstall scriptlets of ['busybox'] have failed. If the intention is to defer them to first boot, then please place them into pkg_postinst_ontarget_${PN} (). Deferring to first boot via 'exit 1' is no longer supported. Details of the failure are in image-devel/1.0-r2/temp/log.do_rootfs. and log.do_rootfs shows: update-alternatives: Error: not linking image-devel/1.0-r2/rootfs/usr/bin/base32 to /usr/bin/busybox.nosuid since image-devel/1.0-r2/rootfs/usr/bin/base32 exists and is not a link Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.32.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.32.bb b/meta/recipes-core/coreutils/coreutils_8.32.bb
index 320f93bdc2..c1962ccb90 100644
--- a/meta/recipes-core/coreutils/coreutils_8.32.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.32.bb
@@ -117,7 +117,7 @@ inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"
# Make hostname's priority higher than busybox but lower than net-tools
ALTERNATIVE_PRIORITY[hostname] = "90"
-ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 nice printenv mktemp df"
+ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base32 base64 nice printenv mktemp df"
ALTERNATIVE_${PN}-doc = "base64.1 nice.1 mktemp.1 df.1 groups.1 kill.1 uptime.1 stat.1 hostname.1"
ALTERNATIVE_LINK_NAME[hostname.1] = "${mandir}/man1/hostname.1"