summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLi Zhou <li.zhou@windriver.com>2016-11-07 11:02:16 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-15 15:18:49 +0000
commitaafbc548ebc66dc0d703526f9a98f784e9c9605b (patch)
tree7fdeca0ad84f851b7585315a82fbe4e6fa7a5a8c
parent7bac3652c2ea0c4d60b1830bc07f2c4c2aaed0ae (diff)
downloadopenembedded-core-contrib-aafbc548ebc66dc0d703526f9a98f784e9c9605b.tar.gz
db: disable the ARM assembler mutex code
The swpb in macro MUTEX_SET will cause "undefined instruction" error on the new arm arches which don't support this assembly instruction any more. If use ldrex/strex to replace swpb, the old arm arches don't support them. So to avoid this issue, just disable the ARM assembler mutex code, and use the default pthreads mutex. Signed-off-by: Li Zhou <li.zhou@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/db/db_6.0.35.bb9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta/recipes-support/db/db_6.0.35.bb b/meta/recipes-support/db/db_6.0.35.bb
index f60edf9566..b1bec0e487 100644
--- a/meta/recipes-support/db/db_6.0.35.bb
+++ b/meta/recipes-support/db/db_6.0.35.bb
@@ -77,15 +77,6 @@ do_configure() {
oe_runconf
}
-# Override the MUTEX setting here, the POSIX library is
-# the default - "POSIX/pthreads/library".
-# Don't ignore the nice SWP instruction on the ARM:
-# These enable the ARM assembler mutex code
-ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
-MUTEX = ""
-MUTEX_arm = "${ARM_MUTEX}"
-MUTEX_armeb = "${ARM_MUTEX}"
-EXTRA_OECONF += "${MUTEX}"
EXTRA_OEMAKE_append_class-target = " LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
EXTRA_OEMAKE += "STRIP=true docdir=${docdir}/db/"