aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-04-06 11:19:11 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-06 10:31:00 +0100
commitc17411edfc08e4937405f33a354e0d308c6964a1 (patch)
treea45a972b545ab7a900d6f32a9ed41678651a5492
parent1ae11a6ea5ff82f6492a880ff45e19f3779918da (diff)
downloadopenembedded-core-contrib-c17411edfc08e4937405f33a354e0d308c6964a1.tar.gz
ffmpeg: Make configure options explicit
Currently ffmpeg builds libraries that are packaged but never appear in PACKAGES. Add PACKAGECONFIGs for all libraries, and make sure PACKAGES_DYNAMIC lists all dynamic packages. Default choice (build all except libavresample) does not change. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb
index 7dfcf094f3..0296ada0aa 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb
@@ -29,9 +29,21 @@ DEPENDS = "alsa-lib zlib libogg yasm-native"
inherit autotools pkgconfig
-PACKAGECONFIG ??= "avdevice avfilter bzlib gpl lzma theora x264 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xv', '', d)}"
+PACKAGECONFIG ??= "avdevice avfilter avcodec avformat swresample swscale postproc \
+ bzlib gpl lzma theora x264 \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xv', '', d)}"
+
+# libraries to build in addition to avutil
PACKAGECONFIG[avdevice] = "--enable-avdevice,--disable-avdevice"
PACKAGECONFIG[avfilter] = "--enable-avfilter,--disable-avfilter"
+PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec"
+PACKAGECONFIG[avformat] = "--enable-avformat,--disable-avformat"
+PACKAGECONFIG[swresample] = "--enable-swresample,--disable-swresample"
+PACKAGECONFIG[swscale] = "--enable-swscale,--disable-swscale"
+PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc"
+PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample"
+
+# features to support
PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2"
PACKAGECONFIG[faac] = "--enable-libfaac,--disable-libfaac,faac"
PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl"
@@ -80,7 +92,7 @@ do_configure() {
${S}/configure ${EXTRA_OECONF}
}
-PACKAGES_DYNAMIC += "^lib(av(codec|device|filter|format|util)|swscale).*"
+PACKAGES_DYNAMIC += "^lib(av(codec|device|filter|format|util|resample)|swscale|swresample|postproc).*"
python populate_packages_prepend() {
av_libdir = d.expand('${libdir}')