aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-04-06 11:19:12 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-06 10:31:00 +0100
commit4438a1125bb15ed19c78833f4d8a5b108cd91d30 (patch)
treee4a0b941437f304f276bb56955620b1e50947e4f
parentc17411edfc08e4937405f33a354e0d308c6964a1 (diff)
downloadopenembedded-core-contrib-4438a1125bb15ed19c78833f4d8a5b108cd91d30.tar.gz
ffmpeg, gstreamer1.0-libav: add textrel INSANE_SKIPs
ffmpeg disables PIC on some platforms even when --enable-pic is set, apparently for performance reasons. Add INSANE_SKIPS for the relevant packages. Fixes [YOCTO #9375]. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb11
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc3
2 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb
index 0296ada0aa..1dfbb9b04c 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.0.bb
@@ -94,6 +94,17 @@ do_configure() {
PACKAGES_DYNAMIC += "^lib(av(codec|device|filter|format|util|resample)|swscale|swresample|postproc).*"
+# ffmpeg disables PIC on some platforms (e.g. x86-32)
+INSANE_SKIP_${MLPREFIX}libavcodec = "textrel"
+INSANE_SKIP_${MLPREFIX}libavdevice = "textrel"
+INSANE_SKIP_${MLPREFIX}libavfilter = "textrel"
+INSANE_SKIP_${MLPREFIX}libavformat = "textrel"
+INSANE_SKIP_${MLPREFIX}libavutil = "textrel"
+INSANE_SKIP_${MLPREFIX}libavresample = "textrel"
+INSANE_SKIP_${MLPREFIX}libswscale = "textrel"
+INSANE_SKIP_${MLPREFIX}libswresample = "textrel"
+INSANE_SKIP_${MLPREFIX}libpostproc = "textrel"
+
python populate_packages_prepend() {
av_libdir = d.expand('${libdir}')
av_pkgconfig = d.expand('${libdir}/pkgconfig')
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
index 598a349e02..363101e1a4 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
@@ -41,3 +41,6 @@ FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
# http://errors.yoctoproject.org/Errors/Details/20493/
ARM_INSTRUCTION_SET_armv4 = "arm"
ARM_INSTRUCTION_SET_armv5 = "arm"
+
+# ffmpeg/libav disables PIC on some platforms (e.g. x86-32)
+INSANE_SKIP_${PN} = "textrel"