summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-02-27 18:47:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-28 13:20:21 +0000
commit9e1f7ebe2529fb7f4728dd67ae60341a61861a50 (patch)
tree63e551777d72800d6da5575c76a6115d5561ec0c
parent4a558a5f2db68538e0edad798ddf48eb9510a7d6 (diff)
downloadopenembedded-core-contrib-9e1f7ebe2529fb7f4728dd67ae60341a61861a50.tar.gz
python3: depend on qemu-native, not qemu-helper-native
qemu-helper-native would erroneously pull in the qemu system parts, where we only want usermode parts for pgo. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3_3.7.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.2.bb b/meta/recipes-devtools/python/python3_3.7.2.bb
index 4a1cbae867..9626ee546b 100644
--- a/meta/recipes-devtools/python/python3_3.7.2.bb
+++ b/meta/recipes-devtools/python/python3_3.7.2.bb
@@ -72,7 +72,7 @@ PACKAGECONFIG_class-native ??= "readline"
PACKAGECONFIG_class-nativesdk ??= "readline"
PACKAGECONFIG[readline] = ",,readline"
# Use profile guided optimisation by running PyBench inside qemu-user
-PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-helper-native"
+PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
PACKAGECONFIG[tk] = ",,tk"
CPPFLAGS_append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"