summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <ming.liu@windriver.com>2013-10-20 18:48:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-26 15:53:24 +0100
commit15ba35aebd7550e53e9f2f35de6b709937dbb55c (patch)
tree244c0c795ebf8697cbbd6f4660982f9c89ed54a4
parentbe566b6f77423f7f676bc6b0511966651d687871 (diff)
downloadopenembedded-core-contrib-15ba35aebd7550e53e9f2f35de6b709937dbb55c.tar.gz
libarchive: replace += with _append for appending to OVERRIDES variables
In some cases, it's unfit to use "+=" in a conditional appending, we would end up with the variable being set rather than being appended, which is not it mean to. Signed-off-by: Ming Liu <ming.liu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-extended/libarchive/libarchive_2.8.5.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_2.8.5.bb b/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
index 1842bf71ea..3bcb7fb885 100644
--- a/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
+++ b/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
@@ -7,13 +7,13 @@ PR = "r0"
PACKAGECONFIG ?= "libxml2 zlib bz2"
-PACKAGECONFIG_class-target += "\
+PACKAGECONFIG_append_class-target = "\
${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
${@base_contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \
${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
"
-PACKAGECONFIG_class-nativesdk += "largefile"
+PACKAGECONFIG_append_class-nativesdk = " largefile"
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"