summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-08-28 15:28:40 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-30 17:10:23 +0100
commitb850ee597e7116cc2a7546853f2b976c891196ef (patch)
treebdc1dd62dc41d17e98b26403389a5a93cb41470e
parent584af667e0000129bcb5c9e8108485f2f6590eaf (diff)
downloadopenembedded-core-contrib-b850ee597e7116cc2a7546853f2b976c891196ef.tar.gz
perf: v5.3+ build fixes
In the 5.3+ perf builds, there are multiple unistd.h files that need to be kept in sync. So not only do we update one, we update both to ensure that libc-headers and the perf build are in sync. perf checks some key files itself to be sure they are in sync, and bits.h can be out of sync. There's no build error that results with bits.h at the moment, but we still make sure they are in sync to avoid the configure/compile warning. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index af0410c88d..7f00df0f8e 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -242,6 +242,10 @@ do_configure_prepend () {
# unistd.h can be out of sync between libc-headers and the captured version in the perf source
# so we copy it from the sysroot unistd.h to the perf unistd.h
install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
+ install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
+
+ # bits.h can have the same issuen as unistd.h, so we make the tools variant take precedence
+ install -D -m0644 ${S}/tools/include/linux/bits.h ${S}/include/linux/bits.h
}
python do_package_prepend() {