aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-10-29 22:10:08 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-10-31 18:01:55 +0100
commitdac48ff1192cd6e4d39aa6e1696e91336d371d97 (patch)
tree1a55f21775ca9c04176b7c664da7d88f394319ef
parent12fe0f0b503f76995a975b1e87d5d652d7f6a24b (diff)
downloadopenembedded-core-contrib-dac48ff1192cd6e4d39aa6e1696e91336d371d97.tar.gz
python-2.7.2: fix build issues when additional modules are linked against host or native libpython instead of target
* -L. is needed to find right libpython * -L${STAGING_LIBDIR} is needed ie for python-zlib to find right zlib Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index af14adbbb3..45d8350376 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -51,6 +51,7 @@ do_compile() {
install -m 0644 Makefile Makefile.orig
sed -i -e 's,${includedir},${STAGING_INCDIR},' Makefile
sed -i -e 's,${libdir},${STAGING_LIBDIR},' Makefile
+ sed -i -e 's,LDFLAGS=,LDFLAGS=-L. -L${STAGING_LIBDIR},' Makefile
install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
# save copy of it now, because if we do it in do_install and
# then call do_install twice we get Makefile.orig == Makefile.sysroot