aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2016-08-18 17:15:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-23 17:44:17 +0100
commit948f0bd162f0b1b0375db884e99a2338f47e8527 (patch)
treef53506eebd49e3837879894daf068d7f088d292c
parent55061a43926baf6ff0e17aed02efd299ebba3c24 (diff)
downloadopenembedded-core-contrib-948f0bd162f0b1b0375db884e99a2338f47e8527.tar.gz
gettext_0.16.1: use musl gettext implementation
gettext uses internal symbols to detect whether the implementation is compatible with GNU gettext. However, these symbols don't are not part of the public API, they are specific to glibc. While musl implements the GNU gettext *API* version 1 and 2 http://www.openwall.com/lists/musl/2015/04/16/3 it doesn't implement glibc internals. This means that gettext fails to detect musl's working implementation. More recent versions of gettext have changed the way GNU gettext compatibility is done https://lists.gnu.org/archive/html/bug-gettext/2016-04/msg00000.html http://git.savannah.gnu.org/cgit/gettext.git/commit/gettext-runtime/m4/gettext.m4?id=b67399b40bc5bf3165b09e6a095ec941d4b30a97 and while we could backport the corresponding patch to gettext.m4, we avoid doing that so as to avoid any potential GPL-v3 issues. So instead we force ./configure to assume that the gettext implementation of the c-library (musl) is compatible. As a side-effect, this also reduces image sizes as the internal gettext implementation isn't built anymore, and it's otherwise packaged into the main gettext package which blows up the image as the main gettext package contains a lot of things. Similarly, libintl.h isn't generated anymore, as the one from musl is OK. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
index 8b6f0a71b0..5a58578e22 100644
--- a/meta/recipes-core/gettext/gettext_0.16.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.16.1.bb
@@ -31,6 +31,11 @@ PARALLEL_MAKE = ""
inherit autotools texinfo
EXTRA_OECONF += "--without-lisp --disable-csharp --disable-openmp --without-emacs"
+EXTRA_OECONF_append_libc-musl = "\
+ gt_cv_func_gnugettext1_libc=yes \
+ gt_cv_func_gnugettext2_libc=yes \
+ "
+
acpaths = '-I ${S}/autoconf-lib-link/m4/ \
-I ${S}/gettext-runtime/m4 \
-I ${S}/gettext-tools/m4'
@@ -41,7 +46,6 @@ do_configure_prepend() {
do_install_append_libc-musl () {
rm -f ${D}${libdir}/charset.alias
- rm -f ${D}${includedir}/libintl.h
}
# these lack the .x behind the .so, but shouldn't be in the -dev package