aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Tricca <flihp@twobit.us>2016-02-20 17:55:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:34 +0000
commit826bfea4b7018c7974ef388facc99ca70bb3654f (patch)
tree304bd8ab72a6a67e6da0cdad077d8e429818e92c
parent5125dd2a5c2e382c47ddeaf0327fc7dc39482023 (diff)
downloadopenembedded-core-contrib-826bfea4b7018c7974ef388facc99ca70bb3654f.tar.gz
sysvinit-inittab: Move start_getty scrip to base_bindir.
When this file is in ${sysconfdir}/init.d, SELinux labels it as a generic init script (initrc_t). This causes problms at runtime because SELinux doesn't let the login process execute generic init script. Moving this helper script to base_bindir results in it being labeled as a generic binary (bin_t). Nearly every SELinux domain is allowed to execute generic binaries and the login process is one of them. Signed-off-by: Philip Tricca <flihp@twobit.us> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
index f539da8dda..c5b8cdca95 100644
--- a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
@@ -17,9 +17,9 @@ do_compile() {
do_install() {
install -d ${D}${sysconfdir}
- install -d ${D}${sysconfdir}/init.d
install -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
- install -m 0755 ${WORKDIR}/start_getty ${D}${sysconfdir}/init.d/start_getty
+ install -d ${D}${base_bindir}
+ install -m 0755 ${WORKDIR}/start_getty ${D}${base_bindir}/start_getty
set -x
tmp="${SERIAL_CONSOLES}"
@@ -27,7 +27,7 @@ do_install() {
do
j=`echo ${i} | sed s/\;/\ /g`
label=`echo ${i} | sed -e 's/tty//' -e 's/^.*;//' -e 's/;.*//'`
- echo "$label:12345:respawn:${sysconfdir}/init.d/start_getty ${j}" >> ${D}${sysconfdir}/inittab
+ echo "$label:12345:respawn:${base_bindir}/start_getty ${j}" >> ${D}${sysconfdir}/inittab
done
if [ "${USE_VT}" = "1" ]; then
@@ -76,7 +76,7 @@ fi
# Set PACKAGE_ARCH appropriately.
PACKAGE_ARCH = "${MACHINE_ARCH}"
-FILES_${PN} = "${sysconfdir}/inittab ${sysconfdir}/init.d/start_getty"
+FILES_${PN} = "${sysconfdir}/inittab ${base_bindir}/start_getty"
CONFFILES_${PN} = "${sysconfdir}/inittab"
USE_VT ?= "1"