aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-14 13:54:22 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-15 11:54:43 +0000
commit77ab0f09546c5f6217a8e2f1bc30cf3d4306e3fa (patch)
tree6bcca326e3d317b79dbee9456bfab93c4dc71cef
parentfc708d88f97e40a5bf929e4e02ed805fb3684ffe (diff)
downloadopenembedded-core-contrib-77ab0f09546c5f6217a8e2f1bc30cf3d4306e3fa.tar.gz
base-passwd: Move update-passwd into a separate package
update-passwd is the only user of the passwd/group.master files and was never used by OE since it wasn't run. This patch packages this separately and adds an appropriate postinst to make the package useful so people can include it as they wish. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.22.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
index 05be23f7e2..5feb924214 100644
--- a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
@@ -1,7 +1,7 @@
SUMMARY = "Base system master password/group files."
DESCRIPTION = "The master copies of the user database files (/etc/passwd and /etc/group). The update-passwd tool is also provided to keep the system databases synchronized with these master files."
SECTION = "base"
-PR = "r5"
+PR = "r9"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
@@ -16,6 +16,11 @@ S = "${WORKDIR}/base-passwd"
inherit autotools
+PACKAGES =+ "${PN}-update"
+FILES_${PN}-update = "${sbindir}/* ${datadir}/${PN}"
+
+ALLOW_EMPTY_${PN} = "1"
+
SSTATEPOSTINSTFUNCS += "base_passwd_sstate_postinst"
do_install () {
@@ -78,3 +83,10 @@ fi
d.setVar('pkg_preinst_${PN}', preinst)
}
+pkg_postinst_${PN}-update () {
+#!/bin/sh
+if [ -n "$D" ]; then
+ exit 0
+fi
+${sbindir}/update-passwd
+}