aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe F. Tonello <eu@felipetonello.com>2013-06-07 10:18:01 -0700
committerSaul Wold <sgw@linux.intel.com>2013-06-10 14:51:27 -0700
commit4f2b3e3831bdc5707eacdab571ab207d8b09953e (patch)
treebdfc24c4c294dce1032a964b7341048ce4272c04
parent74658b66530184b0287152397341fbe411e90c71 (diff)
downloadopenembedded-core-contrib-4f2b3e3831bdc5707eacdab571ab207d8b09953e.tar.gz
libxml2: added python dependency to nativesdk
This is necessary since libxml2 has python dependency. This patch will fix this error: ... /path/to/build/system/4.7.2/ld: cannot find -lpython2.7 ... ERROR: Task 4152 (virtual:nativesdk:meta/recipes-core/libxml/libxml2_2.9.0.bb, do_compile) failed with exit code '1' Signed-off-by: Felipe F. Tonello <eu@felipetonello.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-core/libxml/libxml2.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/libxml/libxml2.inc b/meta/recipes-core/libxml/libxml2.inc
index 91cc14b816..9b2af0ff8a 100644
--- a/meta/recipes-core/libxml/libxml2.inc
+++ b/meta/recipes-core/libxml/libxml2.inc
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
+DEPENDS_class-nativesdk = "nativesdk-python"
DEPENDS_class-native = "python-native"
DEPENDS =+ "zlib"