aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2016-11-29 15:56:52 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-16 08:30:01 +0000
commit2e0b36981c1f91ed0d3d457c370df10a099407af (patch)
treee140d568b8e8009fa1538feaedc10c0081a9e327
parent6a58e12d19c539deac9e90679a68438497a42fa4 (diff)
downloadopenembedded-core-contrib-2e0b36981c1f91ed0d3d457c370df10a099407af.tar.gz
sysvinit-inittab: fix getty device removal
getty devices were not being removed in some cases because device name was not at the end of the line, for example a ttyS1 device: S1:12345:respawn:/bin/start_getty 115200 ttyS1 vt102 Removing this limitation allows sed to remove any line containing the device. Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
index c219cbf9a7..5b9c422caf 100644
--- a/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb
@@ -62,7 +62,7 @@ if [ "x$D" = "x" ] && [ -e /proc/consoles ]; then
k=`echo ${i} | sed s/^.*\://g`
if [ -z "`grep ${j} /proc/consoles`" ]; then
if [ -z "${k}" ] || [ -z "`grep ${k} /proc/consoles`" ] || [ ! -e /dev/${j} ]; then
- sed -i /^.*${j}$/d /etc/inittab
+ sed -i -e /^.*${j}\ /d -e /^.*${j}$/d /etc/inittab
fi
fi
done