aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-08 21:29:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-09 10:50:54 +0000
commitd1109378d730c5cf50240c4d1a468e3aef5208ea (patch)
treeee53e23ca1630baaddf9060efa175063f9a125db
parentcf94de4ddee3e5072da8608c9151301fcec02cd0 (diff)
downloadopenembedded-core-contrib-d1109378d730c5cf50240c4d1a468e3aef5208ea.tar.gz
nss: Fix nss-native so the checksum doesn't change with BUILD_ARCH
Switching between 32 and 64 bit BUILD_ARCH shows: $ bitbake-diffsigs tmp-sstatesamehash*/stamps/*/nss-native/3.27.1-r0.do_compile.sigdata.* basehash changed from 944cc4554a823ba966aeda0ac3d33b79 to 2475db3659c248d81d0e4dadb3c1b4cd Variable SITEINFO_BITS value changed from '32' to '64' We shouldn't have this dependency and it would fail oe-selftest test_sstate_32_64_same_hash if nss-native were included, therefore exclude it. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/nss/nss_3.27.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-support/nss/nss_3.27.1.bb b/meta/recipes-support/nss/nss_3.27.1.bb
index 9aad5bd41c..c89470fb11 100644
--- a/meta/recipes-support/nss/nss_3.27.1.bb
+++ b/meta/recipes-support/nss/nss_3.27.1.bb
@@ -107,6 +107,7 @@ do_compile() {
OS_TEST=${OS_TEST} \
RPATH="${RPATH}"
}
+do_compile[vardepsexclude] += "SITEINFO_BITS"
do_install_prepend_class-nativesdk() {
@@ -180,6 +181,7 @@ do_install() {
install -m 755 -t ${D}/${bindir} $binary
done
}
+do_install[vardepsexclude] += "SITEINFO_BITS"
do_install_append() {
# Create empty .chk files for the NSS libraries at build time. They could