aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-04 17:31:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-07 14:47:20 +0000
commit9792ba51c5caf56d182f1290df41f2a89b85f744 (patch)
treea4027d3e07cb8b5e51d9df513cf10b7bdd07a250
parent61591fe2eea588ff92ff7f81f2ed8844617f5307 (diff)
downloadopenembedded-core-contrib-9792ba51c5caf56d182f1290df41f2a89b85f744.tar.gz
perl-native: Remove .packlist file
This is large and needs fixups to relocate it in each case. We can drop it, save the work and the ~150MB disk space its various copies take up. Its not needed for anything that I can see. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.24.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.24.0.bb b/meta/recipes-devtools/perl/perl-native_5.24.0.bb
index af2ad7b510..42162574b0 100644
--- a/meta/recipes-devtools/perl/perl-native_5.24.0.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.24.0.bb
@@ -106,6 +106,10 @@ do_install () {
for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
done
+
+ # The packlist is large with hardcoded paths meaning it needs relocating
+ # so just remove it.
+ rm ${D}${libdir}/perl/${PV}/.packlist
}
SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"