aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-08-23 13:14:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-24 09:37:02 +0100
commit0a181e26d09978bff850bc6b303de6053f7c53df (patch)
treece2f66ba72281d2389bd0039a5e40f9007362b9b
parentdcd129504ea64986652e2e5907d9badf9373e367 (diff)
downloadopenembedded-core-contrib-0a181e26d09978bff850bc6b303de6053f7c53df.tar.gz
attr: improve reproducibility
Remove all host build references from the attr-ptest package. Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/attr/attr.inc6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-support/attr/attr.inc b/meta/recipes-support/attr/attr.inc
index e8b5d054b3..24ef5adfd3 100644
--- a/meta/recipes-support/attr/attr.inc
+++ b/meta/recipes-support/attr/attr.inc
@@ -32,6 +32,12 @@ do_install_ptest() {
do cp ${S}/include/$i ${D}${PTEST_PATH}/include/; \
done
sed -e 's|; @echo|; echo|' -i ${D}${PTEST_PATH}/test/Makefile
+
+ # Remove any build host references
+ sed -e "s:--sysroot=${STAGING_DIR_TARGET}::g" \
+ -e 's:${HOSTTOOLS_DIR}/::g' \
+ -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
+ -i ${D}${PTEST_PATH}/include/builddefs
}
RDEPENDS_${PN}-ptest = "attr coreutils perl-module-filehandle perl-module-getopt-std perl-module-posix"