summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-30 11:00:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-31 17:51:55 +0100
commit400aae43d08f0b9f787ac0d21cb3c97058d76748 (patch)
treefdc3c805579a9182e9329e68e9b610fc9edca5aa
parent49f81198c5d233a9a2612c3b8366681dd85bea59 (diff)
downloadopenembedded-core-contrib-400aae43d08f0b9f787ac0d21cb3c97058d76748.tar.gz
weston: Add a knob to control simple clients
Some graphics driver implementations ( e.g sgx ) do not yet support APIs from mesa 21.x, and some portions of weston simple clients depend on these APIs, therefore introduce a way to specify all or a selection fo clients to build Fixes clients/weston-simple-dmabuf-feedback.p/simple-dmabuf- feedback.c.o: in function `create_dmabuf_buffer': | simple-dmabuf-feedback.c:(.text+0x1076): undefined reference to `gbm_bo_get_fd_for_plane' Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-graphics/wayland/weston_10.0.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston_10.0.0.bb b/meta/recipes-graphics/wayland/weston_10.0.0.bb
index 8424b4d548..93f7b59659 100644
--- a/meta/recipes-graphics/wayland/weston_10.0.0.bb
+++ b/meta/recipes-graphics/wayland/weston_10.0.0.bb
@@ -45,6 +45,9 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms wayla
shell-fullscreen \
shell-ivi"
+# Can be 'damage', 'im', 'egl', 'shm', 'touch', 'dmabuf-feedback', 'dmabuf-v4l', 'dmabuf-egl' or 'all'
+SIMPLECLIENTS ?= "all"
+
#
# Compositor choices
#
@@ -77,7 +80,7 @@ PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false"
# colord CMS support
PACKAGECONFIG[colord] = "-Dcolor-management-colord=true,-Dcolor-management-colord=false,colord"
# Clients support
-PACKAGECONFIG[clients] = "-Dsimple-clients=all -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false"
+PACKAGECONFIG[clients] = "-Dsimple-clients=${SIMPLECLIENTS} -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false"
# Virtual remote output with GStreamer on DRM backend
PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
# Weston with screen-share support