summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-01-07 09:03:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-08 10:06:30 +0000
commit315f2453515a4cd0f1cc2d1bdddeb0c385aee2d4 (patch)
tree2c866b2fbadd2cddee306f2af3cb3d8234a4671e
parent67aa7069dbe8f5f5f186eb67708ece5c4bd42976 (diff)
downloadopenembedded-core-contrib-315f2453515a4cd0f1cc2d1bdddeb0c385aee2d4.tar.gz
kbd: fix transaction conflict
After kdb upgrades to 2.4.0, vlock.pamd will be copied to /etc/pam.d/vlock when install as [1]. And it will result in below Transaction error during do_rootfs when both vlock and kbd installed: | Transaction test error: file /etc/pam.d/vlock conflicts between attempted installs of vlock-2.2.3-r0.corei7_64 and kbd-2.4.0-r0.corei7_64 So rename vlock to vlock.kbd to fix the gap. [1] https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git/commit/?id=b9cbb05038e01a7c4b3899589c591734e643a281 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/kbd/kbd_2.4.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd_2.4.0.bb b/meta/recipes-core/kbd/kbd_2.4.0.bb
index 4d32263e84..65ba70bf47 100644
--- a/meta/recipes-core/kbd/kbd_2.4.0.bb
+++ b/meta/recipes-core/kbd/kbd_2.4.0.bb
@@ -29,6 +29,13 @@ FILES_${PN}-consoletrans = "${datadir}/consoletrans"
FILES_${PN}-keymaps = "${datadir}/keymaps"
FILES_${PN}-unimaps = "${datadir}/unimaps"
+do_install_append () {
+ if [ ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'yes', '', d)} = yes ] \
+ && [ -f ${D}${sysconfdir}/pam.d/vlock ]; then
+ mv -f ${D}${sysconfdir}/pam.d/vlock ${D}${sysconfdir}/pam.d/vlock.kbd
+ fi
+}
+
inherit update-alternatives
ALTERNATIVE_${PN} = "chvt deallocvt fgconsole openvt showkey \