aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-01-05 13:06:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-06 10:13:39 +0000
commitb1ef094bc0bba54bd54b03c0a3c082d9b6025895 (patch)
tree6d51ec0061d1464d1fc2b15672630379ca14140b
parent5d221ff20dffb2e119047f931e270b5a0ebf2ae1 (diff)
downloadopenembedded-core-contrib-b1ef094bc0bba54bd54b03c0a3c082d9b6025895.tar.gz
lz4: remove ptest changes
This recipe installs the test suite by copying the entire build tree into /usr/share/ptest, which is both wasteful and breaks packaging as lz4-ptest then gets renamed by debian.bbclass to liblz4. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/lz4/lz4_1.7.4.bb10
1 files changed, 1 insertions, 9 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.7.4.bb b/meta/recipes-support/lz4/lz4_1.7.4.bb
index 9e86985d69..86a1ab9ab9 100644
--- a/meta/recipes-support/lz4/lz4_1.7.4.bb
+++ b/meta/recipes-support/lz4/lz4_1.7.4.bb
@@ -17,19 +17,11 @@ SRC_URI = "git://github.com/lz4/lz4.git \
UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
S = "${WORKDIR}/git"
-inherit ptest
-EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
do_install() {
oe_runmake install
}
-do_install_ptest () {
- install -d ${D}${PTEST_PATH}/testsuite
- cp -rf ${S}/* ${D}${PTEST_PATH}/testsuite
-}
-
-RDEPENDS_${PN}-ptest += "make python3"
-
BBCLASSEXTEND = "native nativesdk"