summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2020-09-03 21:31:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-05 22:18:12 +0100
commitd58dc77ab71ea85f8f12ea4ca2e28e0afee60440 (patch)
tree8192904de125fab20735b463e4dbe5ceac831ad3
parent5e6174c58d5e3a95eccee773b6670242cb9ab8f4 (diff)
downloadopenembedded-core-contrib-d58dc77ab71ea85f8f12ea4ca2e28e0afee60440.tar.gz
kea: don't use PACKAGECONFIG inappropriately
The Kea recipe has PACKAGECONFIG options for boost, openssl, and log4cplus. However, these are not optional but mandatory dependencies. Remove the PACKAGECONFIGs and replace with explicit DEPENDS and EXTRA_OECONF. Also the RDEPENDS in the PACKAGECONFIGs are redundant as the library dependencies are generated correctly. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/kea/kea_1.7.7.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-connectivity/kea/kea_1.7.7.bb b/meta/recipes-connectivity/kea/kea_1.7.7.bb
index c69a180833..d2e41e0db2 100644
--- a/meta/recipes-connectivity/kea/kea_1.7.7.bb
+++ b/meta/recipes-connectivity/kea/kea_1.7.7.bb
@@ -5,6 +5,8 @@ SECTION = "connectivity"
LICENSE = "MPL-2.0 & Apache-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=68d95543d2096459290a4e6b9ceccffa"
+DEPENDS = "boost log4cplus openssl"
+
SRC_URI = "\
http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
file://0001-remove-AC_TRY_RUN.patch \
@@ -30,6 +32,10 @@ DEBUG_OPTIMIZATION_append_mipsel = " -O"
BUILD_OPTIMIZATION_remove_mipsel = " -Og"
BUILD_OPTIMIZATION_append_mipsel = " -O"
+EXTRA_OECONF = "--with-boost-libs=-lboost_system \
+ --with-log4cplus=${STAGING_DIR_TARGET}${prefix} \
+ --with-openssl=${STAGING_DIR_TARGET}${prefix}"
+
do_configure_prepend() {
# replace abs_top_builddir to avoid introducing the build path
# don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target
@@ -49,12 +55,6 @@ do_install_append() {
rm -rf "${D}${localstatedir}"
}
-PACKAGECONFIG ??= "openssl log4cplus boost"
-
-PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl"
-PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus"
-PACKAGECONFIG[boost] = "--with-boost-libs=-lboost_system,,boost,boost"
-
FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
FILES_${PN} += "${libdir}/hooks/*.so"