summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-06-20 16:15:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-21 00:26:09 +0100
commit2e8687174e399bb42e935cd74e08e0da67775704 (patch)
treee270285b7bfd23e95ae2fba5781f45cd5de7bd8d
parenta7d3650e346e8a6c2c27c567c4c0bf6a47b47317 (diff)
downloadopenembedded-core-contrib-2e8687174e399bb42e935cd74e08e0da67775704.tar.gz
linux-dummy: Add do_compile_kernelmodules
Fixed: PREFERRED_PROVIDER_virtual/kernel = "linux-dummy" $ bitbake world ERROR: Task do_compile in make-mod-scripts_1.0.bb depends upon non-existent task do_compile_kernelmodules in linux-dummy.bb ERROR: Command execution failed: Exited with 1 Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-dummy.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-dummy.bb b/meta/recipes-kernel/linux/linux-dummy.bb
index e1c7f76760..62cf6f5ea6 100644
--- a/meta/recipes-kernel/linux/linux-dummy.bb
+++ b/meta/recipes-kernel/linux/linux-dummy.bb
@@ -39,6 +39,10 @@ do_compile () {
:
}
+do_compile_kernelmodules() {
+ :
+}
+
do_shared_workdir () {
:
}
@@ -58,3 +62,4 @@ do_deploy() {
addtask bundle_initramfs after do_install before do_deploy
addtask deploy after do_install
addtask shared_workdir after do_compile before do_install
+addtask compile_kernelmodules