summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-09 20:55:57 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-11 06:25:22 -0700
commit93fca640e97643f94ef4f4a5d96c30c971058ec9 (patch)
tree32cf86e15a444be3b4f21737aced2b9cb30f0121
parent9f58bd731f33b90849d7d0cb8153dcfedf336ff4 (diff)
downloadopenembedded-core-contrib-93fca640e97643f94ef4f4a5d96c30c971058ec9.tar.gz
ethtool: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
index dbf7142f18..de38104044 100644
--- a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
+++ b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
@@ -5,12 +5,12 @@ Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Upstream-Status: Inappropriate
(default automake behavior incompatible with ptest)
-Index: ethtool-4.11/configure.ac
+Index: ethtool-4.13/configure.ac
===================================================================
---- ethtool-4.11.orig/configure.ac
-+++ ethtool-4.11/configure.ac
+--- ethtool-4.13.orig/configure.ac
++++ ethtool-4.13/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to p
- AC_INIT(ethtool, 4.11, netdev@vger.kernel.org)
+ AC_INIT(ethtool, 4.13, netdev@vger.kernel.org)
AC_PREREQ(2.52)
AC_CONFIG_SRCDIR([ethtool.c])
-AM_INIT_AUTOMAKE([gnu])