summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-09 20:55:48 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-11 06:25:21 -0700
commit00677e03156228f752476520911c19d4156db8da (patch)
treed9942f4176783078801162537d5a388abb72cf58
parente3a50788bfeabbde226e280803a01dd7f765b2bc (diff)
downloadopenembedded-core-contrib-00677e03156228f752476520911c19d4156db8da.tar.gz
i2c-tools: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/i2c-tools/files/0001-tools-Module.mk-Add-missing-dependencies.patch25
1 files changed, 11 insertions, 14 deletions
diff --git a/meta/recipes-devtools/i2c-tools/files/0001-tools-Module.mk-Add-missing-dependencies.patch b/meta/recipes-devtools/i2c-tools/files/0001-tools-Module.mk-Add-missing-dependencies.patch
index e47c02ab7f..33cf2d42a8 100644
--- a/meta/recipes-devtools/i2c-tools/files/0001-tools-Module.mk-Add-missing-dependencies.patch
+++ b/meta/recipes-devtools/i2c-tools/files/0001-tools-Module.mk-Add-missing-dependencies.patch
@@ -17,12 +17,12 @@ Signed-off-by: Maxin B. John <maxin.john@intel.com>
tools/Module.mk | 10 +++++-----
2 files changed, 12 insertions(+), 5 deletions(-)
-diff --git a/lib/Module.mk b/lib/Module.mk
-index 8a58f5b..67afe91 100644
---- a/lib/Module.mk
-+++ b/lib/Module.mk
-@@ -37,6 +37,13 @@ ifeq ($(BUILD_STATIC_LIB),1)
- LIB_TARGETS += $(LIB_STLIBNAME)
+Index: i2c-tools-4.0/lib/Module.mk
+===================================================================
+--- i2c-tools-4.0.orig/lib/Module.mk
++++ i2c-tools-4.0/lib/Module.mk
+@@ -35,6 +35,13 @@ LIB_TARGETS += $(LIB_STLIBNAME)
+ LIB_OBJECTS += smbus.ao
endif
+# Library file to link against (static or dynamic)
@@ -35,11 +35,11 @@ index 8a58f5b..67afe91 100644
#
# Libraries
#
-diff --git a/tools/Module.mk b/tools/Module.mk
-index 6421a23..609de7a 100644
---- a/tools/Module.mk
-+++ b/tools/Module.mk
-@@ -24,19 +24,19 @@ TOOLS_TARGETS := i2cdetect i2cdump i2cset i2cget i2ctransfer
+Index: i2c-tools-4.0/tools/Module.mk
+===================================================================
+--- i2c-tools-4.0.orig/tools/Module.mk
++++ i2c-tools-4.0/tools/Module.mk
+@@ -24,19 +24,19 @@ TOOLS_TARGETS := i2cdetect i2cdump i2cse
# Programs
#
@@ -64,6 +64,3 @@ index 6421a23..609de7a 100644
$(CC) $(LDFLAGS) -o $@ $^ $(TOOLS_LDFLAGS)
#
---
-2.4.0
-