aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-09-22 02:36:55 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-10-12 20:17:27 -0700
commit3ee56bcf0d43e6334c3f8a9d8920effddecf2580 (patch)
tree750bfb50b4459bd694317596f5b51da5606eb512
parent1a2311c8fa9a3703568cd390c44639fe3335023e (diff)
downloadopenembedded-core-contrib-3ee56bcf0d43e6334c3f8a9d8920effddecf2580.tar.gz
xcb-proto: create .pyc files for python2
Its Makefile's do_install creates .pyc files for python3, now also create them for python2 so that they will be recorded by manifest, and can be cleaned correctly. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
index 8bdca32b71..7d4a6b4364 100644
--- a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
@@ -28,3 +28,10 @@ RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
BBCLASSEXTEND = "native nativesdk"
+
+do_install_append() {
+ # Makefile's do_install creates .pyc files for python3, now also create
+ # them for python2 so that they will be recorded by manifest, and can be
+ # cleaned correctly.
+ python -m py_compile ${D}${libdir}/xcb-proto/xcbgen/*.py
+}