aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2016-06-09 14:27:05 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:42:38 +0100
commit537afef2209bef327a28234207d1ef7e4e596a6e (patch)
tree91e4604111b71154200792a9ebf892a19dcc2fb3
parent8db2be8b246362aff9931a31882fa3bab0043419 (diff)
downloadopenembedded-core-contrib-537afef2209bef327a28234207d1ef7e4e596a6e.tar.gz
weston-init: Use bitbake path variable
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb1
-rwxr-xr-xmeta/recipes-graphics/wayland/weston-init/weston-start2
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index e4e2701af7..291cd16b2a 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -15,6 +15,7 @@ do_install() {
# Install weston-start script
install -Dm755 ${WORKDIR}/weston-start ${D}${bindir}/weston-start
sed -i 's,@DATADIR@,${datadir},g' ${D}${bindir}/weston-start
+ sed -i 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${bindir}/weston-start
}
inherit allarch update-rc.d distro_features_check systemd
diff --git a/meta/recipes-graphics/wayland/weston-init/weston-start b/meta/recipes-graphics/wayland/weston-init/weston-start
index 72ba4b7079..4b41576103 100755
--- a/meta/recipes-graphics/wayland/weston-init/weston-start
+++ b/meta/recipes-graphics/wayland/weston-init/weston-start
@@ -69,4 +69,4 @@ if test -z "$XDG_RUNTIME_DIR"; then
chmod 0700 $XDG_RUNTIME_DIR
fi
-exec openvt $openvt_args -- $launcher $weston_args --log=/var/log/weston.log
+exec openvt $openvt_args -- $launcher $weston_args --log=@LOCALSTATEDIR@/log/weston.log