aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-11-13 11:00:25 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-21 13:02:43 +0000
commitae62a9953e219df5147ed4a5ae3f4163d51cff28 (patch)
tree005e7b50cdb5e1f3a059ac94a6cf12949b897d64
parent8b8c40bdbd09ddd1409dc30e04ef847f6a15f109 (diff)
downloadopenembedded-core-contrib-ae62a9953e219df5147ed4a5ae3f4163d51cff28.tar.gz
recipetool: create: fix failure handling included dicts
If a setup dict in a python setup.py file pulled in the contents of another dict (e.g. **otherdict), then we got an error when mapping the keys because the key is None in that case. Skip those keys to avoid the error (we pick up the values directly in any case). A quick reproducer for this issue: recipetool create https://files.pythonhosted.org/packages/source/p/pyqtgraph/pyqtgraph-0.10.0.tar.gz Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--scripts/lib/recipetool/create_buildsys_python.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/lib/recipetool/create_buildsys_python.py b/scripts/lib/recipetool/create_buildsys_python.py
index ec5449bee9..5bd2aa337c 100644
--- a/scripts/lib/recipetool/create_buildsys_python.py
+++ b/scripts/lib/recipetool/create_buildsys_python.py
@@ -356,6 +356,8 @@ class PythonRecipeHandler(RecipeHandler):
# Naive mapping of setup() arguments to PKG-INFO field names
for d in [info, non_literals]:
for key, value in list(d.items()):
+ if key is None:
+ continue
new_key = _map(key)
if new_key != key:
del d[key]