aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-11-13 16:06:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-21 13:02:44 +0000
commit9839de8861c5fb2067664542045c0728653bbcb4 (patch)
tree44005b13bc1134d540bb468c08bde1ec45f68a9f
parent638b4ac5279225b89edcd411e39aa2c22617dcd5 (diff)
downloadopenembedded-core-contrib-9839de8861c5fb2067664542045c0728653bbcb4.tar.gz
iproute2: upgrade to 4.13
- 0001-include-stdint.h-explicitly-for-UINT16_MAX.patch is already applied to upstream. - Rebase two patches. Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2/0001-include-stdint.h-explicitly-for-UINT16_MAX.patch32
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2/0001-ip-Remove-unneed-header.patch16
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2/0001-iproute2-de-bash-scripts.patch11
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2_4.13.0.bb (renamed from meta/recipes-connectivity/iproute2/iproute2_4.11.0.bb)5
4 files changed, 15 insertions, 49 deletions
diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-include-stdint.h-explicitly-for-UINT16_MAX.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-include-stdint.h-explicitly-for-UINT16_MAX.patch
deleted file mode 100644
index eb0c0abbab..0000000000
--- a/meta/recipes-connectivity/iproute2/iproute2/0001-include-stdint.h-explicitly-for-UINT16_MAX.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 3c885d87befc706bb923933b9819de6fe2de897e Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 20 May 2017 14:03:19 -0700
-Subject: [PATCH] include stdint.h explicitly for UINT16_MAX)
-
-Fixes
-| tc_core.c:190:29: error: 'UINT16_MAX' undeclared (first use in this function); did you mean '__INT16_MAX__'?
-| if ((sz >> s->size_log) > UINT16_MAX) {
-| ^~~~~~~~~~
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- tc/tc_core.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/tc/tc_core.c b/tc/tc_core.c
-index 7bbe0d7..821b741 100644
---- a/tc/tc_core.c
-+++ b/tc/tc_core.c
-@@ -12,6 +12,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <stdint.h>
- #include <unistd.h>
- #include <syslog.h>
- #include <fcntl.h>
---
-2.13.0
-
diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-ip-Remove-unneed-header.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-ip-Remove-unneed-header.patch
index a9f8db6945..a9027c5b58 100644
--- a/meta/recipes-connectivity/iproute2/iproute2/0001-ip-Remove-unneed-header.patch
+++ b/meta/recipes-connectivity/iproute2/iproute2/0001-ip-Remove-unneed-header.patch
@@ -1,6 +1,6 @@
-From f58fc99c88a54135e55a6e0956ce8ae71078d1cc Mon Sep 17 00:00:00 2001
+From 02ed10fc5215c4a32e6740b0a0c2439659be6801 Mon Sep 17 00:00:00 2001
From: Changhyeok Bae <changhyeok.bae@gmail.com>
-Date: Mon, 12 Jun 2017 04:29:07 +0000
+Date: Mon, 13 Nov 2017 15:59:35 +0000
Subject: [PATCH] ip: Remove unneed header
Fix redefinition of struct ethhdr with a suitably patched musl libc
@@ -8,23 +8,23 @@ that suppresses the kernel if_ether.h.
Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
-Upstream-Status: Submitted [netdev@vger.kernel.org]
+Upstream-Status: Pending [netdev@vger.kernel.org]
---
ip/iplink_bridge.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/ip/iplink_bridge.c b/ip/iplink_bridge.c
-index 818b43c..f065b22 100644
+index cccdec1..f065b22 100644
--- a/ip/iplink_bridge.c
+++ b/ip/iplink_bridge.c
-@@ -15,7 +15,6 @@
+@@ -13,7 +13,6 @@
+ #include <stdlib.h>
+ #include <string.h>
#include <netinet/in.h>
+-#include <netinet/ether.h>
#include <linux/if_link.h>
#include <linux/if_bridge.h>
--#include <netinet/ether.h>
#include <net/if.h>
-
- #include "rt_names.h"
--
2.7.4
diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-iproute2-de-bash-scripts.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-iproute2-de-bash-scripts.patch
index 39c7d40319..c3d3fea9c2 100644
--- a/meta/recipes-connectivity/iproute2/iproute2/0001-iproute2-de-bash-scripts.patch
+++ b/meta/recipes-connectivity/iproute2/iproute2/0001-iproute2-de-bash-scripts.patch
@@ -5,14 +5,13 @@ de-bash these two scripts to make iproute2 not depend on bash.
Upstream-Status: Pending
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-
---
- ip/ifcfg | 15 ++++++++-------
- ip/rtpr | 2 +-
+ ip/ifcfg | 15 ++++++++-------
+ ip/rtpr | 2 +-
2 files changed, 9 insertions(+), 8 deletions(-)
diff --git a/ip/ifcfg b/ip/ifcfg
-index 083d9df..60bcf1f 100644
+index 30a2dc4..8677b2e 100644
--- a/ip/ifcfg
+++ b/ip/ifcfg
@@ -1,12 +1,13 @@
@@ -43,7 +42,7 @@ index 083d9df..60bcf1f 100644
-ip route add unreachable 255.255.255.255 >& /dev/null
+ip route add unreachable 224.0.0.0/24 > /dev/null 2>&1
+ip route add unreachable 255.255.255.255 > /dev/null 2>&1
- if [ `ip link ls $dev | grep -c MULTICAST` -ge 1 ]; then
+ if [ "`ip link ls $dev | grep -c MULTICAST`" -ge 1 ]; then
- ip route add 224.0.0.0/4 dev $dev scope global >& /dev/null
+ ip route add 224.0.0.0/4 dev $dev scope global > /dev/null 2>&1
fi
@@ -60,5 +59,5 @@ index c3629fd..674198d 100644
exec tr "[\\\\]" "[
]"
--
-1.7.9.5
+2.7.4
diff --git a/meta/recipes-connectivity/iproute2/iproute2_4.11.0.bb b/meta/recipes-connectivity/iproute2/iproute2_4.13.0.bb
index dbd0545436..32bf0d52f1 100644
--- a/meta/recipes-connectivity/iproute2/iproute2_4.11.0.bb
+++ b/meta/recipes-connectivity/iproute2/iproute2_4.13.0.bb
@@ -4,12 +4,11 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BP}.tar.xz \
file://configure-cross.patch \
file://0001-iproute2-de-bash-scripts.patch \
file://0001-libc-compat.h-add-musl-workaround.patch \
- file://0001-include-stdint.h-explicitly-for-UINT16_MAX.patch \
file://0001-ip-Remove-unneed-header.patch \
"
-SRC_URI[md5sum] = "7a9498de88bcca95c305df6108ae197e"
-SRC_URI[sha256sum] = "72671028bda696d0cb8f48ec8e702581c3a501caeed33eec3a81d7041cbc8026"
+SRC_URI[md5sum] = "69dc9e3ece3296890278f0de478330c8"
+SRC_URI[sha256sum] = "9cfb81edf8c8509e03daa77cf62aead01c4a827132f6c506578f94cc19415c50"
# CFLAGS are computed in Makefile and reference CCOPTS
#