aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-03-30 08:25:05 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-30 21:23:55 +0100
commit754350eb937c38e1cbd2dd3de26cc93d61d01328 (patch)
treed23b4e76c00a49373c78713a9d505994fb1c63b1
parente721858657b8641fda94f84866c37668580bd7a9 (diff)
downloadopenembedded-core-contrib-754350eb937c38e1cbd2dd3de26cc93d61d01328.tar.gz
linux-yocto/4.4: drm/i915/skl: Fix DMC load on Skylake J0 and K0
[ NUC6 (Skylake) graphics firmware fails to load without this patch. From: Mat Martineau <mathew.j.martineau@linux.intel.com> commit a41c8882592fb80458959b10e37632ce030b68ca upstream. The driver does not load firmware for unknown steppings, so these new steppings must be added to the list. Cc: Rodrigo Vivi <rodrigo.vivi@intel.com> Signed-off-by: Mat Martineau <mathew.j.martineau@linux.intel.com> Reviewed-by: Rodrigo Vivi <rodrigo.vivi@intel.com> Signed-off-by: Rodrigo Vivi <rodrigo.vivi@intel.com> Link: http://patchwork.freedesktop.org/patch/msgid/1454023163-25469-1-git-send-email-mathew.j.martineau@linux.intel.com ] Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.4.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
index dffe96656a..ca8a3bc700 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
@@ -2,8 +2,8 @@ KBRANCH ?= "standard/preempt-rt"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "dfa88200087a7ef73741383c05c14ff2f3978947"
-SRCREV_meta ?= "194a6c1c4b783cff90e925ec26fd77ff0e67fdd5"
+SRCREV_machine ?= "8d68782597a31dd55c018c0be7d6799f89aadbf7"
+SRCREV_meta ?= "28bff6d39803ad83f83e353f158fc1aa14d5492d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
index 07c33649aa..8276dd2805 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.4.3"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
-SRCREV_meta ?= "194a6c1c4b783cff90e925ec26fd77ff0e67fdd5"
+SRCREV_machine ?= "10527a38c88d3e2c314c9e49d1eecb9da56c2d85"
+SRCREV_meta ?= "28bff6d39803ad83f83e353f158fc1aa14d5492d"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.4.bb b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
index 4b57766585..050d2ebeb8 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "861adc8d32fbb0c1f14fb9b7b67222ab711473a1"
-SRCREV_machine_qemuarm64 ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
-SRCREV_machine_qemumips ?= "0b21ee5897cc49c94f42fca9cea4665f76ae7e0e"
-SRCREV_machine_qemuppc ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
-SRCREV_machine_qemux86 ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
-SRCREV_machine_qemux86-64 ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
-SRCREV_machine_qemumips64 ?= "8b25338045fdb88a9cdff808003102643f03083e"
-SRCREV_machine ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
-SRCREV_meta ?= "194a6c1c4b783cff90e925ec26fd77ff0e67fdd5"
+SRCREV_machine_qemuarm ?= "435a6d77355ee83be321d9ee69d448eb530fb8e1"
+SRCREV_machine_qemuarm64 ?= "10527a38c88d3e2c314c9e49d1eecb9da56c2d85"
+SRCREV_machine_qemumips ?= "fb72c22307829d134fc6584fe4735377110a2fc2"
+SRCREV_machine_qemuppc ?= "10527a38c88d3e2c314c9e49d1eecb9da56c2d85"
+SRCREV_machine_qemux86 ?= "10527a38c88d3e2c314c9e49d1eecb9da56c2d85"
+SRCREV_machine_qemux86-64 ?= "10527a38c88d3e2c314c9e49d1eecb9da56c2d85"
+SRCREV_machine_qemumips64 ?= "2fd1a928c13bd7eac5e1086859355314e210b909"
+SRCREV_machine ?= "10527a38c88d3e2c314c9e49d1eecb9da56c2d85"
+SRCREV_meta ?= "28bff6d39803ad83f83e353f158fc1aa14d5492d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"