aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-03-22 20:53:51 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-24 21:44:27 +0000
commit7ae7277a577b2732eff7812860a7c7967644e532 (patch)
tree27d437b873a15bdb85d998fdff68df680fe78338
parente838b581397bbea9a0f4d74648fcc250073db1ae (diff)
downloadopenembedded-core-contrib-7ae7277a577b2732eff7812860a7c7967644e532.tar.gz
python-pygobject: use Python 2 instead of Python 3
Ideally this would be an option but that means conditional inherits. For now Python 2 is clearly the default Python in oe-core so switch to Python 2 instead of 3. This stops python3 being pulled inadvertently into builds, and appearing in images that have ptest-pkgs installed (via dbus-test). Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-pygobject_3.18.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python-pygobject_3.18.2.bb b/meta/recipes-devtools/python/python-pygobject_3.18.2.bb
index e61d75ca3e..8fe1d63423 100644
--- a/meta/recipes-devtools/python/python-pygobject_3.18.2.bb
+++ b/meta/recipes-devtools/python/python-pygobject_3.18.2.bb
@@ -3,9 +3,9 @@ SECTION = "devel/python"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
-inherit autotools pkgconfig gnomebase distutils3-base gobject-introspection
+inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
-DEPENDS += "python3 glib-2.0 gnome-common"
+DEPENDS += "python glib-2.0 gnome-common"
SRCNAME="pygobject"
SRC_URI = " \
@@ -20,6 +20,6 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
BBCLASSEXTEND = "native"
-EXTRA_OECONF = "--disable-cairo"
+EXTRA_OECONF = "--disable-cairo --with-python=python2.7"
-RDEPENDS_${PN} += "python3-setuptools"
+RDEPENDS_${PN} += "python-setuptools"