aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-04-13 12:12:09 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-14 10:58:28 +0100
commitec13eb0b19ee1d433329af0dd88ac5b31b13c1af (patch)
tree8fdcdea4cb57f8e6c6a61aa8bec56148c5a9d9de
parent6a5e2b2196e5654fc54ba5b2e51a390c966fd1b7 (diff)
downloadopenembedded-core-contrib-ec13eb0b19ee1d433329af0dd88ac5b31b13c1af.tar.gz
linux-yocto/4.4: gpio-pca953x: fix the "drive" property cannot read/write
The gpio_drive_show/store use incorrect gpio_desc, this causes the drive sysfs property cannot be used, This patch fixes this issue Upstream-status: Inappropriate, custom code for legacy userspace Signed-off-by: Yong Li <yong.b.li@intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.4.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
index 87b46e48c5..9ae4174f96 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "8611de4e967b16bd5b63714045329d621ee744d0"
+SRCREV_machine ?= "d5a75e64945b378d22b136d8c33a1e9120c3bbb9"
SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
index 9bae4faeb0..b6a5fea6cb 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.4.3"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
+SRCREV_machine ?= "0148b3601f29b159b4f84c1478ff1859bbd48efe"
SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.4.bb b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
index 7aeb7c35db..8a9e671266 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "8809b2c36a60829bb9a7c3b04cdf42e95d8e93ae"
-SRCREV_machine_qemuarm64 ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
-SRCREV_machine_qemumips ?= "6a62ed62536c0f50050e24ee385b9e3965d43c97"
-SRCREV_machine_qemuppc ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
-SRCREV_machine_qemux86 ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
-SRCREV_machine_qemux86-64 ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
-SRCREV_machine_qemumips64 ?= "c61be23279c09c6906571de734b583dc7eacedc6"
-SRCREV_machine ?= "73481a3abd4ee49c1cf5561fea997275f535098e"
+SRCREV_machine_qemuarm ?= "a1201019dd589ee33964da46a8402c7e00133ee2"
+SRCREV_machine_qemuarm64 ?= "0148b3601f29b159b4f84c1478ff1859bbd48efe"
+SRCREV_machine_qemumips ?= "2f8a14c3f7c6372b00bfa4fea186f277d8125963"
+SRCREV_machine_qemuppc ?= "0148b3601f29b159b4f84c1478ff1859bbd48efe"
+SRCREV_machine_qemux86 ?= "0148b3601f29b159b4f84c1478ff1859bbd48efe"
+SRCREV_machine_qemux86-64 ?= "0148b3601f29b159b4f84c1478ff1859bbd48efe"
+SRCREV_machine_qemumips64 ?= "b65cb9e6c3ed6e8f97150d4de0f651c7cd1c4fdf"
+SRCREV_machine ?= "0148b3601f29b159b4f84c1478ff1859bbd48efe"
SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \