aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-12-23 13:38:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-02 13:01:33 +0000
commit13a8d3869b0fe0ebdddcee37fb48c5b9cdf718ba (patch)
tree9244d90f5911cd5d181e3bd4813614c49d5e0940
parente46b00a6810eaed27a24495cacb19e565de59fec (diff)
downloadopenembedded-core-contrib-13a8d3869b0fe0ebdddcee37fb48c5b9cdf718ba.tar.gz
e2fsprogs: silence debugfs
debugfs echos the commands when it is executing a script, but as the scripts used at rootfs time are long this massively inflates the do_rootfs log. Comment out the echo so that the rootfs isn't 20K lines longer than it needs to be. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/quiet-debugfs.patch19
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/quiet-debugfs.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/quiet-debugfs.patch
new file mode 100644
index 0000000000..830e9d57a5
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42.8/quiet-debugfs.patch
@@ -0,0 +1,19 @@
+When executing a script don't echo every command, as we do this for entire
+filesystems at rootfs time.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/debugfs/debugfs.c b/debugfs/debugfs.c
+index 5590295..ac57292 100644
+--- a/debugfs/debugfs.c
++++ b/debugfs/debugfs.c
+@@ -2378,7 +2378,7 @@ static int source_file(const char *cmd_file, int ss_idx)
+ cp = strchr(buf, '\r');
+ if (cp)
+ *cp = 0;
+- printf("debugfs: %s\n", buf);
++ /*printf("debugfs: %s\n", buf);*/
+ retval = ss_execute_line(ss_idx, buf);
+ if (retval) {
+ ss_perror(ss_idx, retval, buf);
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
index 22ad925fe2..6175ce7281 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
@@ -9,6 +9,7 @@ SRC_URI += "file://acinclude.m4 \
file://debugfs-extent-header.patch \
file://populate-extfs.sh \
file://e2fsprogs-fix-tests-f_extent_oobounds.patch \
+ file://quiet-debugfs.patch \
"
SRC_URI[md5sum] = "8ef664b6eb698aa6b733df59b17b9ed4"