aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Goodbody <andrew.goodbody@cambrionix.com>2016-08-31 15:05:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-01 22:24:24 +0100
commit5bdcf5672c6e3cce52fe5ba0a5a83bf17f3c979b (patch)
treeb829736ff1197ca4bf656be6c033c8a356bdaabd
parentc3adf8c6f33a90f3185c4b4105d0dba6ca10b26f (diff)
downloadopenembedded-core-contrib-5bdcf5672c6e3cce52fe5ba0a5a83bf17f3c979b.tar.gz
Fix out of tree builds of u-boot with gold linker
Need to reference config.mk file in source tree which is no longer the current directory when using out of tree builds. Signed-off-by: Andrew Goodbody <andrew.goodbody@cambrionix.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index 9e19c4f70f..915da8e744 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -67,7 +67,7 @@ UBOOT_ENV_SYMLINK ?= "${UBOOT_ENV}-${MACHINE}.${UBOOT_ENV_SUFFIX}"
do_compile () {
if [ "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
- sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' config.mk
+ sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' ${S}/config.mk
fi
unset LDFLAGS