aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-08-22 17:05:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-01 21:57:45 +0100
commit42d30fb128a2f385ee7f4eab8e2fcfe3e191f09b (patch)
treea8fccf9f6cf29dee00ec05a217941d9c3d6ced4a
parent7b21b4d786b6639e9f5f4d8cae26d6a1b0669714 (diff)
downloadopenembedded-core-contrib-42d30fb128a2f385ee7f4eab8e2fcfe3e191f09b.tar.gz
libxml2: control ipv6 support based on DISTRO_FEATURES
Add PACKAGECONFIG for ipv6 and control it based on DISTRO_FEATURES. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.4.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.4.bb b/meta/recipes-core/libxml/libxml2_2.9.4.bb
index e2febf0c60..265d2b73a9 100644
--- a/meta/recipes-core/libxml/libxml2_2.9.4.bb
+++ b/meta/recipes-core/libxml/libxml2_2.9.4.bb
@@ -38,8 +38,11 @@ RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us glibc-gconv-ibm
export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
-PACKAGECONFIG ??= "python"
+PACKAGECONFIG ??= "python \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
+"
PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
# WARNING: zlib is require for RPM use
EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"