summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo@ribalda.com>2019-07-25 09:21:10 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-26 08:41:02 +0100
commit1b562506d46ee54414dbdbee9c3f6a3345fa16d0 (patch)
tree1a7acf476639071e72e31f2a569b311cc799786c
parent2623d9d2f243128e50be9ed6fb5bb222b3fe9fa0 (diff)
downloadopenembedded-core-contrib-1b562506d46ee54414dbdbee9c3f6a3345fa16d0.tar.gz
packagegroup-core-base-utils: Make it machine specific
Recipe makes use of the variable MACHINE_FEATURES, which is machine specific: ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "kbd", "", d)} This patch avoids multiconfig errors such as: ERROR: mc:qt5222:packagegroup-core-base-utils-1.0-r0 do_package_qa_setscene: Error executing a python function in exec_python_func() autogenerated: The stack trace of python calls that resulted in this exception/failure was: File: 'exec_python_func() autogenerated', lineno: 2, function: <module> 0001: *** 0002:do_package_qa_setscene(d) 0003: File: '/workdir/repo/poky/meta/classes/insane.bbclass', lineno: 1026, function: do_package_qa_setscene 1022:SSTATETASKS += "do_package_qa" 1023:do_package_qa[sstate-inputdirs] = "" 1024:do_package_qa[sstate-outputdirs] = "" 1025:python do_package_qa_setscene () { *** 1026: sstate_setscene(d) 1027:} 1028:addtask do_package_qa_setscene 1029: 1030:python do_qa_staging() { Signed-off-by: Ricardo Ribalda Delgado <ricardo@ribalda.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb b/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
index 611e0cafcc..18e227144a 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
@@ -5,6 +5,8 @@
SUMMARY = "Full-featured set of base utils"
DESCRIPTION = "Package group bringing in packages needed to provide much of the base utils type functionality found in busybox"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
inherit packagegroup
VIRTUAL-RUNTIME_vim ?= "vim-tiny"