aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-09-17 21:12:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-23 23:21:43 +0100
commitc71cbdd557476b7669c28b44f56e21ce0d0c53dc (patch)
treee14f30dcdec736f156e51196db3e480e7468bbca
parent3fdad451afcc16b1fa94024310b4d26333ca7de9 (diff)
downloadopenembedded-core-contrib-c71cbdd557476b7669c28b44f56e21ce0d0c53dc.tar.gz
openssh: Security fix CVE-2015-8325
openssh < 7.2p2 Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--meta/recipes-connectivity/openssh/openssh/CVE-2015-8325.patch33
-rw-r--r--meta/recipes-connectivity/openssh/openssh_7.1p2.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh/CVE-2015-8325.patch b/meta/recipes-connectivity/openssh/openssh/CVE-2015-8325.patch
new file mode 100644
index 0000000000..05e08534c9
--- /dev/null
+++ b/meta/recipes-connectivity/openssh/openssh/CVE-2015-8325.patch
@@ -0,0 +1,33 @@
+From 85bdcd7c92fe7ff133bbc4e10a65c91810f88755 Mon Sep 17 00:00:00 2001
+From: Damien Miller <djm@mindrot.org>
+Date: Wed, 13 Apr 2016 10:39:57 +1000
+Subject: [PATCH] ignore PAM environment vars when UseLogin=yes
+
+If PAM is configured to read user-specified environment variables
+and UseLogin=yes in sshd_config, then a hostile local user may
+attack /bin/login via LD_PRELOAD or similar environment variables
+set via PAM.
+
+CVE-2015-8325, found by Shayan Sadigh, via Colin Watson
+
+Upstream-Status: Backport
+CVE: CVE-2015-8325
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ session.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: openssh-7.1p2/session.c
+===================================================================
+--- openssh-7.1p2.orig/session.c
++++ openssh-7.1p2/session.c
+@@ -1315,7 +1315,7 @@ do_setup_env(Session *s, const char *she
+ * Pull in any environment variables that may have
+ * been set by PAM.
+ */
+- if (options.use_pam) {
++ if (options.use_pam && !options.use_login) {
+ char **p;
+
+ p = fetch_pam_child_environment();
diff --git a/meta/recipes-connectivity/openssh/openssh_7.1p2.bb b/meta/recipes-connectivity/openssh/openssh_7.1p2.bb
index 51c82c74a3..7c8bc2082d 100644
--- a/meta/recipes-connectivity/openssh/openssh_7.1p2.bb
+++ b/meta/recipes-connectivity/openssh/openssh_7.1p2.bb
@@ -29,6 +29,7 @@ SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.
file://CVE-2016-6210_p2.patch \
file://CVE-2016-6210_p3.patch \
file://CVE-2016-6515.patch \
+ file://CVE-2015-8325.patch \
"
PAM_SRC_URI = "file://sshd"