aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2013-03-18 18:55:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 11:52:21 +0000
commit643ac87145eba5dc105377041bc3deb163b62926 (patch)
tree0266f969d5e9021d7d86d71d5c9a97dad42ef073
parent5704dfa690a625abcface432cf5f9c9bc3ee8abd (diff)
downloadopenembedded-core-contrib-643ac87145eba5dc105377041bc3deb163b62926.tar.gz
layer.conf: avoid unnecessary early expansion with :=
bitbake handles immediate expansions of LAYERDIR for us automatically. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta-hob/conf/layer.conf6
-rw-r--r--meta-skeleton/conf/layer.conf6
-rw-r--r--meta/conf/layer.conf6
3 files changed, 9 insertions, 9 deletions
diff --git a/meta-hob/conf/layer.conf b/meta-hob/conf/layer.conf
index ea977e2cc3..6df27ac5a3 100644
--- a/meta-hob/conf/layer.conf
+++ b/meta-hob/conf/layer.conf
@@ -1,11 +1,11 @@
# We have a conf and classes directory, add to BBPATH
-BBPATH := "${BBPATH}:${LAYERDIR}"
+BBPATH .= ":${LAYERDIR}"
# We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
BBFILE_COLLECTIONS += "hob"
-BBFILE_PATTERN_hob := "^${LAYERDIR}/"
+BBFILE_PATTERN_hob = "^${LAYERDIR}/"
BBFILE_PRIORITY_hob = "1"
# This should only be incremented on significant changes that will
diff --git a/meta-skeleton/conf/layer.conf b/meta-skeleton/conf/layer.conf
index 4cf476711d..10031c1e2a 100644
--- a/meta-skeleton/conf/layer.conf
+++ b/meta-skeleton/conf/layer.conf
@@ -1,11 +1,11 @@
# We have a conf and classes directory, add to BBPATH
-BBPATH := "${BBPATH}:${LAYERDIR}"
+BBPATH .= ":${LAYERDIR}"
# We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
BBFILE_COLLECTIONS += "skeleton"
-BBFILE_PATTERN_skeleton := "^${LAYERDIR}/"
+BBFILE_PATTERN_skeleton = "^${LAYERDIR}/"
BBFILE_PRIORITY_skeleton = "1"
# This should only be incremented on significant changes that will
diff --git a/meta/conf/layer.conf b/meta/conf/layer.conf
index 6e5cd0cf8d..81f1071a91 100644
--- a/meta/conf/layer.conf
+++ b/meta/conf/layer.conf
@@ -4,7 +4,7 @@ BBPATH .= ":${LAYERDIR}"
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
BBFILE_COLLECTIONS += "core"
-BBFILE_PATTERN_core := "^${LAYERDIR}/"
+BBFILE_PATTERN_core = "^${LAYERDIR}/"
BBFILE_PRIORITY_core = "5"
# This should only be incremented on significant changes that will
@@ -12,10 +12,10 @@ BBFILE_PRIORITY_core = "5"
LAYERVERSION_core = "1"
# Set a variable to get to the top of the metadata location
-COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'
+COREBASE = '${@os.path.normpath("${LAYERDIR}/../")}'
# Set path to qemu image tests included in this layer
-QEMUIMAGETESTS := "${COREBASE}/scripts/qemuimage-tests"
+QEMUIMAGETESTS = "${COREBASE}/scripts/qemuimage-tests"
SIGGEN_EXCLUDERECIPES_ABISAFE += " \
sysvinit-inittab \