aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-02-09 18:37:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-12 14:04:24 +0000
commitb5bd54b1640c1e59960c260dd6521ba2500df204 (patch)
treeee350ae16cb7f114343b1eb370c40838b01efeab
parent479620023aa0af9467ca1d2807cf7bedd73327f6 (diff)
downloadopenembedded-core-contrib-b5bd54b1640c1e59960c260dd6521ba2500df204.tar.gz
linux-yocto: tweak console boot check
boot/main: don't check console device file on fs when booting with initrd/initramfs In case of initrd/initramfs /dev/console might not exist that early as devtmpfs is mounted a bit later by /init process so disable this check in that case. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb6
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.19.bb18
3 files changed, 14 insertions, 14 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
index 79eebb49f5..591981aa31 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "7759e970a7e106bd37bd62b63ab67bdae54a2152"
-SRCREV_meta ?= "4c0da29403e242f3d429196cf4a03200211e6ff4"
+SRCREV_machine ?= "3059029718900250904b9f587e37ba22fb949ea6"
+SRCREV_meta ?= "5d93f38b0eed56071261895aefecfca287595536"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.19;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
index 69d0a6136d..bb2ea2d991 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
@@ -15,9 +15,9 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine_qemuarm ?= "64017daf053fdb31049248e45f42e0abd55117d3"
-SRCREV_machine ?= "ad24af0809e17882e33fb4bd77426e691f47b46d"
-SRCREV_meta ?= "4c0da29403e242f3d429196cf4a03200211e6ff4"
+SRCREV_machine_qemuarm ?= "6cc861e796ab19a6827cf9996e7755f1875d553e"
+SRCREV_machine ?= "11e0e616ed095bb8012e1b4a231254c9656a0193"
+SRCREV_meta ?= "5d93f38b0eed56071261895aefecfca287595536"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.19.bb b/meta/recipes-kernel/linux/linux-yocto_4.19.bb
index 11f7e15bad..13d6eb0ea0 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.19.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "v4.19/standard/base"
KBRANCH_qemux86-64 ?= "v4.19/standard/base"
KBRANCH_qemumips64 ?= "v4.19/standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "21a0a68be12c2e549fcc63c3253f22123dc46b72"
-SRCREV_machine_qemuarm64 ?= "ad24af0809e17882e33fb4bd77426e691f47b46d"
-SRCREV_machine_qemumips ?= "27542dfa0e04bf9d8453a172fce459176787fd97"
-SRCREV_machine_qemuppc ?= "ad24af0809e17882e33fb4bd77426e691f47b46d"
-SRCREV_machine_qemux86 ?= "ad24af0809e17882e33fb4bd77426e691f47b46d"
-SRCREV_machine_qemux86-64 ?= "ad24af0809e17882e33fb4bd77426e691f47b46d"
-SRCREV_machine_qemumips64 ?= "5abad938eff63706ca30fdf09b31f1c7b36f5308"
-SRCREV_machine ?= "ad24af0809e17882e33fb4bd77426e691f47b46d"
-SRCREV_meta ?= "4c0da29403e242f3d429196cf4a03200211e6ff4"
+SRCREV_machine_qemuarm ?= "0d83500d7377b68aeb42387350bb41dd7dc04315"
+SRCREV_machine_qemuarm64 ?= "11e0e616ed095bb8012e1b4a231254c9656a0193"
+SRCREV_machine_qemumips ?= "0169796412b83d8835f3f9b81d19efe008199fdd"
+SRCREV_machine_qemuppc ?= "11e0e616ed095bb8012e1b4a231254c9656a0193"
+SRCREV_machine_qemux86 ?= "11e0e616ed095bb8012e1b4a231254c9656a0193"
+SRCREV_machine_qemux86-64 ?= "11e0e616ed095bb8012e1b4a231254c9656a0193"
+SRCREV_machine_qemumips64 ?= "fc7a2bf24e0e39b6a260f8650a3c8d497b8cdcfd"
+SRCREV_machine ?= "11e0e616ed095bb8012e1b4a231254c9656a0193"
+SRCREV_meta ?= "5d93f38b0eed56071261895aefecfca287595536"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.19;destsuffix=${KMETA}"