aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <joshua.lock@collabora.co.uk>2015-10-13 17:15:27 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:20:17 +0000
commite9b843d3b3dba6d118e57a7e0dd225dc4004a31a (patch)
tree3d2d8c59b020a78be39aeb6166a7f136ca437109
parentf5df27374b1c06280a8481325f9cf802ee5e9371 (diff)
downloadopenembedded-core-contrib-e9b843d3b3dba6d118e57a7e0dd225dc4004a31a.tar.gz
weston: add a PACKAGECONFIG option for xwayland support
Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/wayland/weston_1.8.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.8.0.bb b/meta/recipes-graphics/wayland/weston_1.8.0.bb
index 6234a8c6f5..40df6e1936 100644
--- a/meta/recipes-graphics/wayland/weston_1.8.0.bb
+++ b/meta/recipes-graphics/wayland/weston_1.8.0.bb
@@ -26,7 +26,6 @@ DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
DEPENDS += "wayland libinput virtual/egl pango"
EXTRA_OECONF = "--enable-setuid-install \
- --disable-xwayland \
--enable-simple-clients \
--enable-clients \
--enable-demo-clients-install \
@@ -74,6 +73,8 @@ PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp"
PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
# Weston with systemd-login support
PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus"
+# Weston with Xwayland support
+PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland,libxcb libxcursor cairo"
do_install_append() {
# Weston doesn't need the .la files to load modules, so wipe them