aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-10-19 19:56:12 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:19:53 +0000
commitbb5849423d7ed299b4c895a14d3754121ff68069 (patch)
tree9a3060d7a99d017d81c447f0ae72d11931dac978
parent53aae968a6972f152f4b540deaf79963765ff559 (diff)
downloadopenembedded-core-contrib-bb5849423d7ed299b4c895a14d3754121ff68069.tar.gz
python: don't append -D__SOFTFP__ to TARGET_CC_ARCH for armv6/armv7a
Remove obsolete hack which seems to date back to (at least) 2009. It's potentially harmful as python TARGET_CC_ARCH flags can leak through to other packages via the sysroot _sysconfigdata.py. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3_3.4.3.bb5
-rw-r--r--meta/recipes-devtools/python/python_2.7.9.bb5
2 files changed, 1 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/python3_3.4.3.bb b/meta/recipes-devtools/python/python3_3.4.3.bb
index f61d278d79..a33f10f01f 100644
--- a/meta/recipes-devtools/python/python3_3.4.3.bb
+++ b/meta/recipes-devtools/python/python3_3.4.3.bb
@@ -56,10 +56,7 @@ CACHED_CONFIGUREVARS = "ac_cv_have_chflags=no \
ac_cv_file__dev_ptmx=yes \
ac_cv_file__dev_ptc=no \
"
-# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources
-#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :(
-TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
-TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
+
TARGET_CC_ARCH += "-DNDEBUG -fno-inline"
EXTRA_OEMAKE += "CROSS_COMPILE=yes"
EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ --without-ensurepip"
diff --git a/meta/recipes-devtools/python/python_2.7.9.bb b/meta/recipes-devtools/python/python_2.7.9.bb
index f7e2f272f4..bc20417674 100644
--- a/meta/recipes-devtools/python/python_2.7.9.bb
+++ b/meta/recipes-devtools/python/python_2.7.9.bb
@@ -34,11 +34,6 @@ inherit autotools multilib_header python-dir pythonnative
CONFIGUREOPTS += " --with-system-ffi "
-# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources
-#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :(
-TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
-TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
-
# The following is a hack until we drop ac_cv_sizeof_off_t from site files
EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)} ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no"