aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-09-22 13:18:54 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-22 11:23:01 -0700
commit8cc08e44cf3e969c124456d459c6c06a76cad018 (patch)
tree01335bd747330c7630688b0d3da45111f95c8ab9
parent636ffaec45db57a3eb5ae1ca9a81b763dc1a6a53 (diff)
downloadopenembedded-core-contrib-8cc08e44cf3e969c124456d459c6c06a76cad018.tar.gz
linux-yocto: enable pci and CRYPTO_DEV_VIRTIO
With recent kernels and the latest openssl we observe hangs when there is not sufficient entropy in the system before crypto is used (i.e. OpenVSwitch or openssh server). This was mainly observed on qemuarm64, but can happen elsewhere. So we enable CRYPTO_DEV_VIRTIO in the main virtio fragment and enable PCI for qemuarm64 to ensure that entropy is available. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.18.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
index 605dc69589..24a2c59328 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "c37a14708f5b618602f84f83f902346e055824c3"
-SRCREV_meta ?= "c35dd5cbbdb08dcc4fe35b8e9c0a62d1a157aeaf"
+SRCREV_meta ?= "46a547fa5195c2990e513ae3050376b7670e8287"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb
index 6658adee36..1a53927647 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.18.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "f9cb6c0852260b119014a339332c9f4bee4c074b"
-SRCREV_meta ?= "0e108d3aae16700b48e5944aa96d264e39f8160e"
+SRCREV_meta ?= "607726b2d0b8e1d8c5653003448a24353a88c63b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.18;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
index 20be3c18f3..de22031301 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
@@ -13,7 +13,7 @@ KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "3218be18094b7dfb4471b083c469452c8c7709ce"
-SRCREV_meta ?= "c35dd5cbbdb08dcc4fe35b8e9c0a62d1a157aeaf"
+SRCREV_meta ?= "46a547fa5195c2990e513ae3050376b7670e8287"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
index bb2445160f..69ca1dc0e0 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
@@ -14,7 +14,7 @@ KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "0cdc8564c61958a39704d97e008120bd7c762f60"
-SRCREV_meta ?= "0e108d3aae16700b48e5944aa96d264e39f8160e"
+SRCREV_meta ?= "607726b2d0b8e1d8c5653003448a24353a88c63b"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.14.bb b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
index c931cf8070..7c97d53da1 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "78a16a4d8cfd58f91be412797aac248e811d083b"
SRCREV_machine_qemux86-64 ?= "78a16a4d8cfd58f91be412797aac248e811d083b"
SRCREV_machine_qemumips64 ?= "f074d718736e95e8ed5460bf8e85c7e77ff7df87"
SRCREV_machine ?= "78a16a4d8cfd58f91be412797aac248e811d083b"
-SRCREV_meta ?= "c35dd5cbbdb08dcc4fe35b8e9c0a62d1a157aeaf"
+SRCREV_meta ?= "46a547fa5195c2990e513ae3050376b7670e8287"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.18.bb b/meta/recipes-kernel/linux/linux-yocto_4.18.bb
index 79d3046bd2..948ce3bb95 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.18.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.18.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "0cdc8564c61958a39704d97e008120bd7c762f60"
SRCREV_machine_qemux86-64 ?= "0cdc8564c61958a39704d97e008120bd7c762f60"
SRCREV_machine_qemumips64 ?= "766c469b1707fd3101116f572052a7b8d5ac0658"
SRCREV_machine ?= "0cdc8564c61958a39704d97e008120bd7c762f60"
-SRCREV_meta ?= "0e108d3aae16700b48e5944aa96d264e39f8160e"
+SRCREV_meta ?= "607726b2d0b8e1d8c5653003448a24353a88c63b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.18;destsuffix=${KMETA}"