summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-10-26 14:25:22 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-27 09:44:59 +0100
commit341707513a7c3cfcd797f6631b8daf09ddf5bae8 (patch)
tree45a4b437014c06877489e75423b390b0fbb2cf68
parent8e863e9c57fc26e4158b6c10b04931976c54efb8 (diff)
downloadopenembedded-core-contrib-341707513a7c3cfcd797f6631b8daf09ddf5bae8.tar.gz
linux-yocto/5.14: common-pc: enable CONFIG_ATA_PIIX as built-in
Jacob Kroon reported that generic/custom x86 kernels would no longer boot out of the box since the IDE options were removed and the PATA migration happened. To re-enable that use case, we grab the following kernel configuration change: common-pc*/qemux86*: set CONFIG_ATA_PIIX as built-in Since the IDE options were made obselete in the kernel, and the PATA driver is the replacement, we haven't had one of the commonly used qemu boot devices enabled in our kernel by default. We change CONFIG_ATA_PIIX to built-in, to re-enable use cases that boot from default qemu 'hardware'. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Reported-by: Jacob Kroon <jacob.kroon@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.14.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.14.bb
index 245ea46ceb..3d53a32d40 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.14.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "cddeec4e197612a11f5a3d746a15825c66040830"
-SRCREV_meta ?= "6f8d397886b014e8c7ef4ffb08a489fd7b6a0a3f"
+SRCREV_meta ?= "dc308bdf001acd203ed912852bafbf779696d507"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.14;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.14.bb
index c98a5fa428..0683912eb2 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.14.bb
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine:qemuarm ?= "ace292aaba53e26d1888bebda95bbadfd417c2a5"
SRCREV_machine ?= "ca50fa43acc878c2590a7f5cb93aef0ba17591aa"
-SRCREV_meta ?= "6f8d397886b014e8c7ef4ffb08a489fd7b6a0a3f"
+SRCREV_meta ?= "dc308bdf001acd203ed912852bafbf779696d507"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.14.bb b/meta/recipes-kernel/linux/linux-yocto_5.14.bb
index fe7244399a..2d4600746c 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.14.bb
@@ -23,7 +23,7 @@ SRCREV_machine:qemux86 ?= "ca50fa43acc878c2590a7f5cb93aef0ba17591aa"
SRCREV_machine:qemux86-64 ?= "ca50fa43acc878c2590a7f5cb93aef0ba17591aa"
SRCREV_machine:qemumips64 ?= "b8f18794a5a6bb9c6d0190a2006dfbd82f0f5916"
SRCREV_machine ?= "ca50fa43acc878c2590a7f5cb93aef0ba17591aa"
-SRCREV_meta ?= "6f8d397886b014e8c7ef4ffb08a489fd7b6a0a3f"
+SRCREV_meta ?= "dc308bdf001acd203ed912852bafbf779696d507"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same