aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2017-04-15 18:44:05 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-19 10:16:22 +0100
commitcbf1708cf8d9fb8ace5520c9b6fec46c5fc9e9c8 (patch)
tree9cf0f0e0fa14480aaec53b3d6475a7715a47efb3
parent73d3d81fcdb92dd85c6ad1609e3a6eb20f1ea539 (diff)
downloadopenembedded-core-contrib-cbf1708cf8d9fb8ace5520c9b6fec46c5fc9e9c8.tar.gz
mesa-demos: add glut dependency
If the user wants to enable the 'glut' PACKAGECONFIG for mesa-demos, freeglut is required to provide the dependency before the demos can be compiled. NOTE! this is a cross-layer dependency (freeglut is currently only available in meta-oe). However 'glut' is not a default PACKAGECONFIG (so this is allowed). Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
index e80d1e8acb..e43b9effba 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
@@ -40,7 +40,7 @@ PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
-PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,"
+PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,freeglut"
PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"