aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2016-10-28 15:14:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:14 +0000
commit6238faf901956e2a350315a66ca1ce557deaa513 (patch)
tree75d5a5dd3122bfafddb84ead20a8d0da5697b325
parent00d1913520f1572fa7def865e57852c7f25b0ec4 (diff)
downloadopenembedded-core-contrib-6238faf901956e2a350315a66ca1ce557deaa513.tar.gz
build-appliance-image: Fix incorrect PATH
When modifying the PATH variable in .bashrc, double quote characters were used, resulting in expanding the variable $PATH with the value of PATH of the system building the Build Appliance. The original intent was to enter an un-expanded (literal) $PATH. In order to that, one must use single quotes instead of double quotes. [YOCTO#10434] [YOCTO#10504] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index 9d898b4363..5bb655530b 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -63,7 +63,7 @@ fakeroot do_populate_poky_src () {
# Also save (for reference only) the actual SRCREV used to create this image
echo "export BA_SRCREV=${SRCREV}" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
echo "" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
- echo "export PATH=$PATH:/sbin" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
+ echo 'export PATH=$PATH:/sbin' >> ${IMAGE_ROOTFS}/home/builder/.bashrc
echo "" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
echo "# If working behind a proxy and using the provided oe-git-proxy script" >> ${IMAGE_ROOTFS}/home/builder/.bashrc