aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-05-23 19:34:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:24:55 +0100
commitc6f24481b2fc965eeebca5508d68f1b9e5b3f212 (patch)
treec6e8f9aeb1cb87600f95a1929c76f35fced65753
parentc91dbf3ca2faec95195c85b65aa6cab7de9bca2c (diff)
downloadopenembedded-core-contrib-c6f24481b2fc965eeebca5508d68f1b9e5b3f212.tar.gz
tcl: fix sed command in do_install
The -I= and -L= is used for cross compile, target doesn't need, and binconfig.class can handle usr/bin/crossscripts/tclConfig.sh. Fix do_configure error for the recipe which uses tclConfig.sh, for example, postgresql.do_configure: configure: error: header file <tcl.h> is required for Tcl Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.5.bb2
1 files changed, 0 insertions, 2 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.5.bb b/meta/recipes-devtools/tcltk/tcl_8.6.5.bb
index 46fc8a784f..d75232b54e 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.5.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.5.bb
@@ -56,8 +56,6 @@ do_install() {
ln -sf tclsh8.6 ${D}${bindir}/tclsh${VER}
sed -i "s+-L${B}+-L${STAGING_LIBDIR}+g" tclConfig.sh
sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh
- sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh
- sed -i "s,-I${includedir},-I=${includedir},g" tclConfig.sh
install -d ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${libdir}